Tecnología

Android 14 está configurado para bloquear la instalación de ciertas aplicaciones obsoletas

Para reducir el potencial de malware, Android 14 comenzará a bloquear por completo la instalación de aplicaciones dirigidas a versiones obsoletas de Android.

Durante años, las pautas de Google Play Store han garantizado que los desarrolladores de Android mantengan sus aplicaciones actualizadas para usar las últimas funciones y medidas de seguridad de la plataforma Android. Solo este mes, instrucciones se actualizó, lo que requiere que las aplicaciones de Play Store recién incluidas se orienten a Android 12 o superior.

Hasta ahora, estos requisitos mínimos de nivel de API solo se aplicaban a las aplicaciones destinadas a Google Play Store. Si un desarrollador desea crear una aplicación para una versión anterior, puede hacerlo y solicitar a sus usuarios que descarguen el archivo APK manualmente. Del mismo modo, si la aplicación de Android no se ha actualizado después de cambiar las instrucciones, Play Store seguirá ofreciendo la aplicación. para aquellos que lo han instalado una vez antes.

Según la nueva publicación. cambio de código, Android 14 está configurado para ajustar los requisitos de la API, lo que evita por completo la instalación de aplicaciones obsoletas. Este cambio evita que los usuarios carguen ciertos archivos APK en la página y también evita que las tiendas de aplicaciones instalen las mismas aplicaciones.

Inicialmente, los dispositivos con Android 14 solo bloquearán aplicaciones que se dirijan específicamente a versiones anteriores de Android. Con el tiempo, sin embargo, el umbral se elevará a Android 6.0 (Marshmallow), por lo que Google tiene un mecanismo para «aumentar gradualmente [it] hasta.» Sin embargo, es probable que cada fabricante de dispositivos decida el umbral para las aplicaciones obsoletas o si lo implementa o no.

READ  La pista Coconut Mall de Mario Kart 8 recibió una actualización salvaje, e Internet se está dando cuenta

Si está habilitada la aplicación de la versión SDK mínima instalable, impida la instalación de aplicaciones que utilicen una versión de SDK de destino requerida más baja. Esto ayuda a mejorar la seguridad y la privacidad, ya que el malware puede apuntar a versiones antiguas del SDK para evitar el nuevo comportamiento de la API.

Al bloquear estas aplicaciones obsoletas, Google tiene la intención de frenar la propagación de malware en Android. El desarrollador responsable del cambio señala que algunas aplicaciones de malware se han dirigido deliberadamente a versiones anteriores de Android para eludir ciertas protecciones que solo se aplican en las aplicaciones más nuevas.

Si por alguna razón desea o desea instalar una aplicación desactualizada, aún es posible hacerlo utilizando el shell billete nuevo. Dados los pasos adicionales requeridos, es menos probable que alguien haga esto accidentalmente e instale malware accidentalmente.

Más sobre Android 14:

FTC: Utilizamos enlaces de afiliados automáticos que generan ingresos. Más.


Vea más noticias de 9to5Google en YouTube:

Patricio Arocha

Especialista web. Evangelista de viajes. Alborotador. Fanático de la música amigable con los hipster. Experto en comida

Publicaciones relacionadas

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Botón volver arriba
Cerrar
Cerrar